« MBS Xojo Plugins, ver… | Home | MBS Xojo Plugins, ver… »

Visual Studio 2019 dependency


We moved earlier in August 2020 to the newer Visual Studio version 2019 to build our plugins. All our Windows plugins are now build with that version.

But there was/is one problem: Some of the plugins got a new dependency to VCRuntime140_1.dll, which is part of the Visual Studio 2019 runtime libraries. That is annoying since it requires all our users to install those libraries. It would be much easier to not have that dependency and be only relaying on the Visual Studio 2015 libraries. Those are required for FileMaker Pro/Server as well as Xojo and so preinstalled with installing those. And Windows 10 comes with those libraries pre-installed as well.

For MBS Xojo Plugins 21.0 we removed the dependency and we are looking forward to keep all newer versions for at least this year free of the VCRuntime140_1.dll dependency.

For 21.0pr7 we fixed this for WebView2, WindowsHTMLViewer, WindowsStore parts in MBS Xojo Win Plugin and MBS Xojo XMP Plugin. The last plugin to get fixed is MBS Xojo ChartDirector Plugin, where we are able to remove the dependency for next pre-release 8 and the final release next week.

Let us know if you have some questions about this. Please try pr8 later this week. The biggest plugin in space...
14 01 21 - 11:18

Start Chat